Error when STARTing browse from timer 
Author Message
 Error when STARTing browse from timer

In my 32 bit C55 legacy application I want to start a browse automatically
once a day from a timer in main window.
That works alright most of the time, but not if there is a modal dialog
started from another thread. Then I get error message "Unable to open MDI
window, no application active. Do you want to GPF?"

Is that expected behavior, or is it a Clarion bug?
Are there any particular rules for when you should/should not START a
procedure? The docs don't mention anything.
Is it possible to detect that a modal dialog active?
Are there any other known workarounds for this problem?

Best regards,
Roar J?ssund



Sun, 06 Nov 2005 14:06:30 GMT  
 Error when STARTing browse from timer
Roar -

Try posting an event which then starts your thread. e.g.:

 Post(Event:Accepted,?MyMenuChoice)

On Wed, 21 May 2003 06:06:30 GMT, "Roar J?ssund"

Quote:

>Are there any other known workarounds for this problem?

Jeff Slarve  
http://www.jssoftware.com


Sun, 06 Nov 2005 23:28:53 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. NEED TIMER IN SECONDS FROM START OF INPUT SIGNAL

2. Start timer on opening tk_MessageBox?

3. Refreshing browse box with timer

4. Refresh Browse on timer event

5. Timer in browse

6. Automatic Browse Refresh Timer

7. How to use a timer in a browse

8. Error starting omniNames....Invalid object reference error.

9. browsing error (513) and internal error 13

10. Error (513): Internal error 13 (try to browse a pervasive file from dct in C5)

11. start a browse at a certain record

12. Opening a browse and starting on the last page

 

 
Powered by phpBB® Forum Software