PRESS Command and Vanishing Cursor 
Author Message
 PRESS Command and Vanishing Cursor


                       - - - - - - - - - -            
-- [ From: Cooman Software * EMC.Ver #2.5.02 ] --

Does anyone have any idea why after I issue a PRESS command to stuff
characters in the keyboard buffer, the characters appear in a field
correctly but then the cursor vanishes?  It only appears if I change fields
but as long as I stay in the same field, the cursor still is hidden.

Thanks.

Carson Cooman



Wed, 22 Dec 1999 03:00:00 GMT  
 PRESS Command and Vanishing Cursor


                       - - - - - - - - - -            
No help here, just a similar problem.  If I set a "B" (blank) on a field,
the cursor flashes a few times when the user enters the field, then it
disappears..the user doesn't know where he/she is.  I removed the "B",
and let the fields display zeros, and then the field shows the hilite.
Didn't have the time (or skill) to pursue it, settled for the workaround.
Makes a busy looking form, though.



Thu, 23 Dec 1999 03:00:00 GMT  
 PRESS Command and Vanishing Cursor

Haven't tried it, or seen it.  How about using SELECT(?) after PRESSKEY  ??


Quote:

>                       - - - - - - - - - -            
>-- [ From: Cooman Software * EMC.Ver #2.5.02 ] --

>Does anyone have any idea why after I issue a PRESS command to stuff
>characters in the keyboard buffer, the characters appear in a field
>correctly but then the cursor vanishes?  It only appears if I change fields
>but as long as I stay in the same field, the cursor still is hidden.

>Thanks.

>Carson Cooman


Geoff Bomford
ComForMark
Computer services For Marketing
Sydney,  Australia


Fri, 24 Dec 1999 03:00:00 GMT  
 PRESS Command and Vanishing Cursor


                       - - - - - - - - - -            
Hi Tom,


Quote:
>No help here, just a similar problem.  If I set a "B" (blank) on a field,
>the cursor flashes a few times when the user enters the field, then it
>disappears..the user doesn't know where he/she is.  I removed the "B",
>and let the fields display zeros, and then the field shows the hilite.
>Didn't have the time (or skill) to pursue it, settled for the workaround.
>Makes a busy looking form, though.

We use the blank attribute a lot and I haven't noticed this.  What
version of CW are you using?

Best regards,

Arnor Baldvinsson
Allerup Edb
Tel: +45 4675 7122
Fax: +45 4675 7144
Denmark


http://www.icetips.com

Opinions are mine, and mine alone!



Fri, 24 Dec 1999 03:00:00 GMT  
 PRESS Command and Vanishing Cursor


                       - - - - - - - - - -            

Quote:
>>No help here, just a similar problem.  If I set a "B" (blank) on a field,
>>the cursor flashes a few times when the user enters the field, then it
>>disappears..the user doesn't know where he/she is.  I removed the "B",
>>and let the fields display zeros, and then the field shows the hilite.
>>Didn't have the time (or skill) to pursue it, settled for the workaround.
>>Makes a busy looking form, though.

>We use the blank attribute a lot and I haven't noticed this.  What
>version of CW are you using?

Test your app with a different video-driver such as the standard Microsoft
"VGA" (640x480) and "Super VGA" (800x600), to check whether the problem
might be related to your driver.


Fri, 24 Dec 1999 03:00:00 GMT  
 
 [ 5 post ] 

 Relevant Pages 

1. vanishing cursor

2. Vanishing cursor

3. tk 4.0b3 text mark set insert end: cursor vanishes

4. Changing the cursor when control key pressed.

5. Command-key presses

6. Problem with Press command

7. How to capture key-presses (keyboard-presses)???

8. command line mouse cursor

9. A window's -cursor command doesn't report valid options

10. Command to move cursor to end of text widget

11. Tk Command to Position Cursor?

12. "Busy cursor" command for Tk

 

 
Powered by phpBB® Forum Software