LONG in TPS file doesn't show negative numbers 
Author Message
 LONG in TPS file doesn't show negative numbers

Hi All

a strange happening :

A program writes numbers to a file. The format is LONG. On the screen , the
number is negative. As another program reads the field it has become
positive.
I check in the IDE environment with 'browse database' and the file has a
positive number. Even in the IDE I can not change it to negative.

Has anyone any idea why this thing doesn't go negative ??

CW 4 GOLD - CW2003 templates - WIN NT 4.0

Thanks

Hans Vinckier



Fri, 07 Jul 2000 03:00:00 GMT  
 LONG in TPS file doesn't show negative numbers

Hans,
    I'd make sure that the reading program doesn't define the variable as
"ulong", which does not carry a sign bit. That should give no negative numbers
*and* a negative number in the long format will display "funky" (because the
sign bit is the high bit of the number). That's something to check.
    Hope that helps.

    Regards,

    kurtt

Quote:

> A program writes numbers to a file. The format is LONG. On the screen , the
> number is negative. As another program reads the field it has become
> positive.
> I check in the IDE environment with 'browse database' and the file has a
> positive number. Even in the IDE I can not change it to negative.

> Has anyone any idea why this thing doesn't go negative ??



Fri, 07 Jul 2000 03:00:00 GMT  
 LONG in TPS file doesn't show negative numbers

Quote:

>> A program writes numbers to a file. The format is LONG. On the screen ,
the
>> number is negative. As another program reads the field it has become
>> positive.
>> I check in the IDE environment with 'browse database' and the file has a
>> positive number. Even in the IDE I can not change it to negative.

>> Has anyone any idea why this thing doesn't go negative ??

Hans:


sign) so all numbers appears as positive even though they are stored
correctly. Will in the browser, highlight the column that contains the LONG
value and then press Ctrl-P and make sure the format includes the negative
sign.
   Of course this does not help why the other program is not reading it
correctly, but it might help with viewing the file directly.
   Hopes this helps.

Barton Whisler



Fri, 07 Jul 2000 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. CW2.0 - Convert Doesn't Work Properly on My TPS File

2. TPS file with all dimension fields.....doesn't work

3. Using Long File Names (TPS Files) in Clarion

4. number of records for tps file and searching files

5. V/Mac on Mac OS 8.5 doesn't show selection in lists

6. w3.uccb.ns.ca news server doesn't show all postings

7. My Live3D doesn't show WWWinline, Textures and Backgrounds

8. Python 2.3 IDLE doesn't show on Win2000

9. Main Window doesn't show up in my tk app

10. scale doesn't show up with update idletasks

11. canvas doesn't show up in TCL/TK plugin

12. Negative Numbers in Test File

 

 
Powered by phpBB® Forum Software