No BIND on variable 801 - using CFW 2003 
Author Message
 No BIND on variable 801 - using CFW 2003


                       - - - - - - - - - -            
I have two customers using exactly the same program. One gets the following
error:

        Error: (No BIND or variable 801)) attempting to open the current VIEW. Filter
and Range Limits ignored.

The strange this is, is that  only one of the customers gets this error. I
have tested the program and I can't get it to happen. All the relevant
variables in the browse have been bound. What is going on?

For reference, both customers are using WIN95, but the program has been
compiled to 16bit. Does this have something to do with it.

Thanks

Bryan

PC Control Systems Limited
UK



Tue, 28 Mar 2000 03:00:00 GMT  
 No BIND on variable 801 - using CFW 2003


                       - - - - - - - - - -            
Hi Bryan,

Quote:
> I have two customers using exactly the same program.
> One gets the following error:

If you are using the runtime DLLs, are both using 2003 DLLs?

Quote:
> Error: (No BIND or variable 801)) attempting to open
> the current VIEW. Filter and Range Limits ignored.

This looks like the bug that was in 2.001 and prior where if the app
was minimized to the WIN95 taskbar while a browse window was opened,
upon giving the app focus again, this error would be generated.  
HTH.

Best Regards,

Andy Kaczmarczyk
Auratek International



Tue, 28 Mar 2000 03:00:00 GMT  
 No BIND on variable 801 - using CFW 2003

Is the filter user definable?  I came across this problem when a user
definable filter was used once and I forgot to BIND all of the
possible filter fields that the user could choose.


Quote:


>                       - - - - - - - - - -            
>I have two customers using exactly the same program. One gets the following
>error:

>    Error: (No BIND or variable 801)) attempting to open the current VIEW. Filter
>and Range Limits ignored.

>The strange this is, is that  only one of the customers gets this error. I
>have tested the program and I can't get it to happen. All the relevant
>variables in the browse have been bound. What is going on?

>For reference, both customers are using WIN95, but the program has been
>compiled to 16bit. Does this have something to do with it.

>Thanks

>Bryan

>PC Control Systems Limited
>UK

ComForMark
Computer services For Marketing
Sydney,  Australia


Thu, 30 Mar 2000 03:00:00 GMT  
 No BIND on variable 801 - using CFW 2003

Quote:


>                        - - - - - - - - - -
> I have two customers using exactly the same program. One gets the following
> error:

>         Error: (No BIND or variable 801)) attempting to open the current VIEW. Filter
> and Range Limits ignored.

> The strange this is, is that  only one of the customers gets this error. I
> have tested the program and I can't get it to happen. All the relevant
> variables in the browse have been bound. What is going on?

> For reference, both customers are using WIN95, but the program has been
> compiled to 16bit. Does this have something to do with it.

> Thanks

> Bryan

> PC Control Systems Limited
> UK

Look for any procedure you call from that procedure. I had problem
returning from called procedure and getting 801. The error was that I
used RETURN instead DO ProcedureReturn. At begining of program PUSHBIND
was generated and in ProcdureReturn you have POPBIND. If you use
PUSHSBIND without POPBIND, on next file request you will get 801.

Vojin



Mon, 03 Apr 2000 03:00:00 GMT  
 No BIND on variable 801 - using CFW 2003

Thanks for that helpful hint....maybe that should make the Clarion
FAQ....the way I solved it was to just do a bind again.
--

Bradley University, Peoria, IL

"You might be a redneck if: Your wife's best shoes have steel toes."



Tue, 11 Apr 2000 03:00:00 GMT  
 No BIND on variable 801 - using CFW 2003

Quote:

> Thanks for that helpful hint....maybe that should make the Clarion
> FAQ....the way I solved it was to just do a bind again.
> --

> Bradley University, Peoria, IL

> "You might be a redneck if: Your wife's best shoes have steel toes."

I have had several problems with "No BIND on variable 801" also. Could
you repost
and mail the exact problem and solution again please.

Thanx in advance,
Alex.

--
Alex Kwak
Assist Consultancy
Apeldoorn, the Netherlands



Wed, 12 Apr 2000 03:00:00 GMT  
 
 [ 6 post ] 

 Relevant Pages 

1. Error 801: No Bind On Variable when using Clarion Report Writer for Windows

2. No bind on variable View (801) attempting ot open the currewnt view

3. Error: (No Bind on variable(801))

4. No bind on variable (801)

5. Error No Bind on variable 801

6. Help - No BIND on Variable(801)

7. No BIND on variable (801 error

8. File not open (37) and No Bind on variable (801)errors

9. NO BIND on variable 801

10. No Bind on variable (801)

11. ERROR message No Bind on variable(801)

12. ERROR message No Bind on variable(801)

 

 
Powered by phpBB® Forum Software