Keystate problem 
Author Message
 Keystate problem

I have an embed located in the TakeEvent of ThisWindow.

The embed code only gets touched if I have set a module variable in a called
procedure.

When I close the called procedure with CtrlEnter and return to my calling
procedure, my embed code tries to run, but the KEYSTATE is stuck in Ctrl
mode.

Is there a way I can turn of Ctrl mode in the KEYSTATE by hand?

here is my code:

IF ChangingPhase=1
    ChangingPhase=0
    SELECT(?List)
    PRESSKEY(DownKey)
END

When the operator gets control back, the program is stuck in Ctrl mode.

Oh, by the way, if I throw a message in this spot here, the whole problem
goes away.

IF ChangingPhase=1
    ChangingPhase=0
    MESSAGE('Hi there')
    SELECT(?List)
    PRESSKEY(DownKey)
END

Any suggestions?

Mark Knowles
A-Systems Corp.



Tue, 03 Jun 2003 02:22:26 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. Problems, problems, problems

2. Eiffel Problems, Problems, Problems

3. Finn Idiom problems and Re: {rho} problem

4. Combinatorial Problem [ & a new Combinatorial Problem ]

5. Database problem/Memory problem??

6. CW 2003 - Focus problem & a select problem

7. 32bit problem - one problem solved & another found

8. GForth problem or my problem?

9. REXX DLL problems solved (was Re: Problems getting C subcommand to work)

10. HTTP-Access2 problem (was Ruby Google problem)

11. Problem with this excercise problem.

12. RSX problems and texture problems

 

 
Powered by phpBB® Forum Software