CW5.5 and ActiveX (Syntax problems?) 
Author Message
 CW5.5 and ActiveX (Syntax problems?)

We need help from all who are experienced with Clarion and ActiveX:

The following VB code works:

    Set objServer = CreateObject("GELO.Server")

    objServer.DataSource = "DSN=ObjectPro;UID=xxx;PWD=xxx;"

    Set objProductCatalog = objServer.ProductCatalog

    Set objProducts = objProductCatalog.Items(*)

    Count = objProducts.Count

using Jim Kane's code from Clarionmagazine we get the following errors:

OLE TCL

    oletcl.init(,GELO.Server',1)

    oletcl.setprop('DataSource', 'DSN=ObjectPro;UID=xxx;PWD=xxx;')

    oletcl.setprop('ProductCatalog.Items', '*')

    message(oletcl.getprop('ProductCatalog.Items.Count'))

Windows-Errormessage: The code in '0x00000000# point to memory '0x000000'.
Action 'read' cannot be done in memory.

Even the original Clarion code will not work:

Clarion

    ?ObjectPro{Prop:Create} = ('Babel.Server')

    ?ObjectPro{'Datasource'} = 'DSN=ObjectPro;UID=xxx;PWD=xxx;'

    ?objProducts{Prop:Open} = ?ObjectPro{'ProductCatalog.Items(*)'}

    Message(?objProducts{'Count'})

I guess that we do not have the correct syntax.

Thanks for your help.

Frank Gerlinger



Sat, 29 Jan 2005 19:35:22 GMT  
 
 [ 1 post ] 

 Relevant Pages 

1. ActiveX and CW5

2. Does this line contain new CW5 syntax

3. TCP/IP error 503 in CW5=ok in CW5.5b the error

4. LINK ERROR CW5 - CW5.5

5. problem translating nasm syntax to gas syntax

6. Implementing letrec-syntax using only let-syntax and syntax-rules

7. CW5: PROBLEM making DLL - Help!

8. CW5 problem with child records

9. Citrix + CW5 Problem -- Please help!

10. CW5 EE Beta Installation Problem

11. CW5 problem: First Report Detail Group Creeps into Report Header

12. CW5.5 Application Shutdown Problem

 

 
Powered by phpBB® Forum Software