Problem: Variable in Crystal Reports 
Author Message
 Problem: Variable in Crystal Reports

I have a problem in Vb 3.0 and Crystal Reports.

My problem is that I have a textbox in my app. that I want to print in
my report.
I have tryed: Report1.Formulas(0) = "MyFormula = 'Some_text'" and it
works.
But I want to send the text in the textbox, not a static text.
Therefore I tryed: Report1.Formulas(0) = "MyFormula = text1.Text". But
it will not work.

Please help me with this. I'm getting desperate! / Pelle

                       ,,,
                      (. .)
+------------------ooO-(_)-Ooo--------------------+
|                                                 |
|               Pelle Brolin                      |
|                                                 |
|  Gatuadress.: Stall?ngsv?gen 17                 |
|  Postadress.: 522 34  TIDAHOLM                  |
|  Telefon....: 0502 - 157 02                     |
|  Mobiltele..: 0708 - 11 57 02                   |

|  ICQ........: http://www.*-*-*.com/ ; |
|  WWW........: http://www.*-*-*.com/ ~w-14316  |
+-------------------------------------------------+



Wed, 17 Nov 1999 03:00:00 GMT  
 Problem: Variable in Crystal Reports

See answer last time you posted.
--
Les Schmalzbach
(remove nospam- to reply).



Quote:
> I have a problem in Vb 3.0 and Crystal Reports.

> My problem is that I have a textbox in my app. that I want to print in
> my report.
> I have tryed: Report1.Formulas(0) = "MyFormula = 'Some_text'" and it
> works.
> But I want to send the text in the textbox, not a static text.
> Therefore I tryed: Report1.Formulas(0) = "MyFormula = text1.Text". But
> it will not work.

> Please help me with this. I'm getting desperate! / Pelle

>                        ,,,
>                       (. .)
> +------------------ooO-(_)-Ooo--------------------+
> |                                                 |
> |               Pelle Brolin                      |
> |                                                 |
> |  Gatuadress.: Stall?ngsv?gen 17                 |
> |  Postadress.: 522 34  TIDAHOLM                  |
> |  Telefon....: 0502 - 157 02                     |
> |  Mobiltele..: 0708 - 11 57 02                   |

> |  ICQ........: http://wwp.mirabilis.com/411654   |
> |  WWW........: http://home1.swipnet.se/~w-14316  |
> +-------------------------------------------------+



Thu, 18 Nov 1999 03:00:00 GMT  
 Problem: Variable in Crystal Reports

Try  Report1.Formulas(0) = "MyFormula = " & text1.text

B. regards
Luis
+++



Quote:
> I have a problem in Vb 3.0 and Crystal Reports.

> My problem is that I have a textbox in my app. that I want to print in
> my report.
> I have tryed: Report1.Formulas(0) = "MyFormula = 'Some_text'" and it
> works.
> But I want to send the text in the textbox, not a static text.
> Therefore I tryed: Report1.Formulas(0) = "MyFormula = text1.Text". But
> it will not work.

> Please help me with this. I'm getting desperate! / Pelle



Fri, 19 Nov 1999 03:00:00 GMT  
 Problem: Variable in Crystal Reports

Try Report1.Formulas(0) = "MyFormula = '" & text1.Text  & "'"

Quote:

> I have a problem in Vb 3.0 and Crystal Reports.

> My problem is that I have a textbox in my app. that I want to print in
> my report.
> I have tryed: Report1.Formulas(0) = "MyFormula = 'Some_text'" and it
> works.
> But I want to send the text in the textbox, not a static text.
> Therefore I tryed: Report1.Formulas(0) = "MyFormula = text1.Text". But
> it will not work.

> Please help me with this. I'm getting desperate! / Pelle

>                        ,,,
>                       (. .)
> +------------------ooO-(_)-Ooo--------------------+
> |                                                 |
> |               Pelle Brolin                      |
> |                                                 |
> |  Gatuadress.: Stall?ngsv?gen 17                 |
> |  Postadress.: 522 34  TIDAHOLM                  |
> |  Telefon....: 0502 - 157 02                     |
> |  Mobiltele..: 0708 - 11 57 02                   |

> |  ICQ........: http://wwp.mirabilis.com/411654   |
> |  WWW........: http://home1.swipnet.se/~w-14316  |
> +-------------------------------------------------+

--
Email me:  radavis at lgc dot com


Mon, 22 Nov 1999 03:00:00 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Sharing Variables between Crystal Report and sub-report

2. Printing Crystal Reports without Crystal Control ActiveX or Crystal Reports API call

3. Crystal Reports ANd VB 6.0 Printing reports using CRPEAUTO Object, specifying paper orientation problem

4. Crystal Report -- Web Report Problem

5. Crystal Report Problem in reporting!!

6. Crystal Report -- Web Report Problem

7. Crystal Report Problem in reporting!!

8. Problems designing report in crystal reports

9. Crystal Reports Open Report Problem

10. Problem with report in Visual Basic and Crystal Reports

11. Problem refreshing report data in crystal reports 4.6

12. Problem with report in Visual Basic and Crystal Reports(2)

 

 
Powered by phpBB® Forum Software