CreateProcess returning a value of zero 
Author Message
 CreateProcess returning a value of zero

I am working on a conversion project from 16 bit to 32 bit.I am tring
to replace the winexec function with the createprocess 32 bit api
function .  Unfortunetly the function fails returning an error. I am
using the function to launch an application passed in a string. Somehow
the function doesn't likes the path which  invokes the applicaton. I
have tried to pass the address of the string . But that did not work
either. Would any of you have any answers to the vexing problem. Or
have seen similar usage of the create process function.
Thanks

Sent via Deja.com http://www.*-*-*.com/
Share what you know. Learn what you don't.



Mon, 11 Feb 2002 03:00:00 GMT  
 CreateProcess returning a value of zero
Look at my post about "Winsock Anomaly" for an example of using
CreateProcess.

HTH
Karl Westberg, MCP

Quote:

>I am working on a conversion project from 16 bit to 32 bit.I am tring
>to replace the winexec function with the createprocess 32 bit api
>function .  Unfortunetly the function fails returning an error. I am
>using the function to launch an application passed in a string. Somehow
>the function doesn't likes the path which  invokes the applicaton. I
>have tried to pass the address of the string . But that did not work
>either. Would any of you have any answers to the vexing problem. Or
>have seen similar usage of the create process function.
>Thanks

>Sent via Deja.com http://www.deja.com/
>Share what you know. Learn what you don't.

begin 666 Karl Westberg, MCP.vcf
M0D5'24XZ5D-!4D0-"E9%4E-)3TXZ,BXQ#0I..E=E<W1B97)G.TMA<FP-"D9.

M8F5R9T!S;F5T+FYE= T*4D56.C$Y.3DP.#(V5#$S-3DP-UH-"D5.1#I60T%2
#1 T*
`
end


Mon, 11 Feb 2002 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. CreateProcess Api returns a bad Pid

2. CreateProcess() returned error code 0x000000C1H

3. CreateProcess() returned error code 0x000000C1H

4. shell a file (as with shellExecute) AND wait for its return (as with CreateProcess)

5. CreateProcess API does not return Process or Thread IDs for 16-bit apps

6. CreateProcess returns 0

7. Replace Function returns Nothing instead of Zero-length string

8. Microsoft Outlook Express 5 and Netscape, the AttachmentCount property always returns zero

9. Mid returning Zero Length String - sort of

10. problem using component with asp page -- result of function not returned, instead original value returned

11. Text field in Excel returns null when led by a zero

12. Oracle Returns Zero (0) USing ADO

 

 
Powered by phpBB® Forum Software