Problem adding new record to inner join recordset... 
Author Message
 Problem adding new record to inner join recordset...

>      What _used_ to work (and still does if I paste the query into
> Access and edit the data there) is to supply values for all but
> PRODUCT_FAMILY_NAME, and the new record would be saved to PRODUCT_GROUP
> with no problems.  Now, for some reason, after the end of the Validate()
> event, I get two identical untrappable error dialogs that say simply
> "Object doesn't support this property or method", without any apparent
> way of finding out what object, property, or method it's talking about.
>      I've also tried editing it in a DBGrid; Oracle returns an error
> saying that a required field is null (even if all values are filled in),
> as if it's also trying to add a new record to PRODUCT_FAMILY.  I tried
> taking the DBGrid out of the picture altogether (even though the client
> wants it there), and still got the same "Object doesn't support..."
> messages.

>     Any ideas what could be happening here & what to do about it?

>     Thanks.

> --

> Stuck using a PC, but still an Amiga guy at heart...

I have the same problem pver here, when i fill in a field just before
I update the recordset, the other fields are blanked out. I look like
a one-to-many problems, but I also have it with one-to-one tables.
I'm using a Jet 2.5 database with VB4-16bit. The code used to work
(and still does) in VB3 and Access 2.0

Good luck

Marcel van der Gragt (you can't pronounce this)

Tue, 05 May 1998 03:00:00 GMT  
 [ 1 post ] 

 Relevant Pages 

1. Problem adding new record to inner join recordset...

2. Problem adding new record to inner join recordset...

3. Problem adding new record to inner join recordset...


5. Query/Recordset problem on inner join with sql oledb provider

6. Problem adding new record to SQL database recordset

7. Problems with adding new records in a recordset

8. Can not add a new record to the recordset based on the INNER JOIN query (SQL Server)

9. Adding a record to a recordset based on a join

10. Using ADO recordsets in an inner join

11. VB5-DB:INNER JOIN on two crosstab recordsets?

12. error updating a recordset using an inner join - please help


Powered by phpBB® Forum Software