DAO3.6 can't install properly on W98... 
Author Message
 DAO3.6 can't install properly on W98...

I wrote a program in VB6 that used to use the data object with Jet 2.5
engine on a .mdb database, and it worked fine. Now I've decided to add
a password feature to the database, so I've upgraded to the DAO 3.6
(I'm forced to do this... or not?) and it works fine on the pc with
vb6 installed on win2000.

So I created a package, but during the package creation the wizard
didn't ask me anything about the db engine to use... I tried the
installation on another pc (win98, just formatted), and I got an error
at the end of the setup, like "the file msadox.dll can't be
registered". I tried anyway to run it and I got a run-time error about
a class not found, followed by a CLSID (I don't remember which).

Ok, I thought, maybe there's something wrong with the DAO 3.6, so I
recompiled the project with DAO 3.51 (and the wizard asked me what to
install... I said all jet x.x engines), but it doesn't work (database
not recognized). With DAO 2.x it's the same.

I hope someone can help me....



ICQ#: 37438061
"...and if they steal your light your heart is still in mine..." - TSP

Mon, 23 Jun 2003 22:07:55 GMT  
 [ 1 post ] 

 Relevant Pages 

1. VB5EE installed now DAO3.0 from Excel won't work on Dev machine

2. 'Canned' data in VB program

3. VB5/DAO3.5 Install

4. error after installing application on W98 system

5. Using a dao3.0 workspace/database from multiple exe's

6. Form doesn't display properly on user's PC

7. CreateDC Fails when not fed 'properly'

8. W95 works, W98 doesn't

9. This W98 PC won't run .VBS??

10. W2K Doesn't Load ActiveX Control But W98 and WXP Do Load ActiveX Control Correctly

11. Installed Program will not function properly

12. DLL not installing properly


Powered by phpBB® Forum Software