Missing AppleScript Command "set language" 
Author Message
 Missing AppleScript Command "set language"

Hi,

I'd like to make scripts like the following.

but the command "set language" is not available!
Please RS, give us such a property for the language.

Script is attachted:

tell application "REALbasic 3.2b5 PPC"

        set language to "English"

        activate
        set buildMacPPC of document 1 to true
        set buildMac68k of document 1 to true
        set buildMacName of document 1 to "MyApp US Classic"

        build document 1
        set buildMacPPC of document 1 to false
        set buildMac68k of document 1 to false
        set buildMacCarbon of document 1 to true
        set buildWin32 of document 1 to true
        set buildMacName of document 1 to "MyApp US Carbon"
        set buildWinName of document 1 to "MyApp US Win.exe"

        build document 1

        set language to "German"

        activate
        set buildMacPPC of document 1 to true
        set buildMac68k of document 1 to true
        set buildMacName of document 1 to "MyApp Classic"

        build document 1
        set buildMacPPC of document 1 to false
        set buildMac68k of document 1 to false
        set buildMacCarbon of document 1 to true
        set buildWin32 of document 1 to true
        set buildMacName of document 1 to "MyApp Carbon"
        set buildWinName of document 1 to "MyApp Win.exe"

        build document 1
end tell

Mfg
Christian

--
PLZ Suche
Das einzige Postleitzahlensuchprogramm fr Mac OS X

Download unter < http://www.*-*-*.com/ >



Thu, 30 Oct 2003 20:41:54 GMT  
 Missing AppleScript Command "set language"
[[ This message was both posted and mailed: see
   the "To," "Cc," and "Newsgroups" headers for details. ]]


Quote:

> I'd like to make scripts like the following.

> but the command "set language" is not available!
> Please RS, give us such a property for the language.

Please submit this request with REALbugs; that'll make it much easier
to justify doing it...

Thanks,
- Joe

--
,------------------------------------------------------------------.
|    Joseph J. Strout         Check out the Mac Web Directory:     |

`------------------------------------------------------------------'



Fri, 31 Oct 2003 22:33:05 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. who set "set tz=....." command orignally

2. string.join(["Tk 4.2p2", "Python 1.4", "Win32", "free"], "for")

3. "Missing" data

4. Running program with "Missing" DLL

5. Amiga 2.0 ARexx - What is "missing"

6. The Dreaded "Missing Subunits"

7. "data segment" missing

8. Missing "crtbegin.o" in GNAT 3.10

9. "data segment" missing

10. Frozen module misses "init.tcl"

11. Finding missed "D0" in numerical constants

12. Missing exponent "E"

 

 
Powered by phpBB® Forum Software