RB uses CPU even when doing nothing 
Author Message
 RB uses CPU even when doing nothing

Hi.
On my G4 Mac OS X.1 computer, when I launch RB 3.5 and use the IDE, my
CPU is used at 30 to 50%.
I mean even when I don't write anything in the code window my CPU
indicates (thanks to CPUMonitor), i.e. I just look at my screen with
RB IDE as front-most application, my CPU is used at 30 to 50%.
How is it possible???

Moreover, one of the soft I have written (that displays a Mandelbrot
set) is slow when displaying the graphic set but do not use my CPU at
100% when doing (i.e. computing and displaying) it: my CPU stays at
80%.
How is it possible???

Thanks



Fri, 30 Apr 2004 20:43:54 GMT  
 RB uses CPU even when doing nothing

Quote:

> On my G4 Mac OS X.1 computer, when I launch RB 3.5 and use the IDE, my
> CPU is used at 30 to 50%.
> I mean even when I don't write anything in the code window my CPU
> indicates (thanks to CPUMonitor), i.e. I just look at my screen with
> RB IDE as front-most application, my CPU is used at 30 to 50%.
> How is it possible???

It's possible because none of the other apps you're running are using
much CPU at all, so RB which sits there and twiddles its thumbs appears
to be using a large percentage of the total.  It's nothing to worry
about, however.

Quote:
> Moreover, one of the soft I have written (that displays a Mandelbrot
> set) is slow when displaying the graphic set but do not use my CPU at
> 100% when doing (i.e. computing and displaying) it: my CPU stays at
> 80%.
> How is it possible???

It's possible because no app can use 100% of a Unix machine.  There are
always other processes running (and in your case, those other processes
in total take up 1/4 as much CPU time as your Mandelbrot app).

Cheers,
- Joe

--
,------------------------------------------------------------------.
|    Joseph J. Strout         Check out the Mac Web Directory:     |

`------------------------------------------------------------------'



Sat, 01 May 2004 00:57:44 GMT  
 RB uses CPU even when doing nothing

Quote:

> Hi.
> On my G4 Mac OS X.1 computer, when I launch RB 3.5 and use the IDE, my
> CPU is used at 30 to 50%.

Perhaps you give your CPU something better to do?
Play music with iTunes or watch a DVD.
RB can be around 1% here :-)

Mfg
Christian

--
Berhmte letzte W?rter (04a)
"Diese Brcke h?lt schon 30 Jahre"

http://www.christians-software.de (Kostenlose Mac/Win Software)



Sat, 01 May 2004 06:49:02 GMT  
 RB uses CPU even when doing nothing

Quote:
> It's possible because none of the other apps you're running are using
> much CPU at all, so RB which sits there and twiddles its thumbs appears
> to be using a large percentage of the total.  It's nothing to worry
> about, however.

You misunderstood I think, so I explain better:
When I launch for exemple TextEdit alone and I don't type text in the
window, CPUMonitor indicates my CPU is at something like 10% of
load... that's nothing because I don't type text and TextEdit is not
doing anything.
But when I launch REALbasic 3.5 and I don't type text in any window,
CPUMonitor indicates my CPU is at something like 50% of load (event if
I do NOTHING).
That's not normal I think! No?

Quote:
> It's possible because no app can use 100% of a Unix machine.  There are
> always other processes running (and in your case, those other processes
> in total take up 1/4 as much CPU time as your Mandelbrot app).

I this case don't speek about the CPU only used by my app, but about
the overall CPU load. There are 20% of CPU free: why doesn't my app
(written in RB) use them when I launch it? Is it because it is slowed
by because it waits after the display?
Thanks.


Sat, 01 May 2004 14:57:02 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Disk (server) requests while doing nothing

2. pep 308: why doing (almost) nothing suffices

3. Odd and Even functions missing in RB

4. NOTHING, NOTHING AT ALL!!

5. Monitoring CPU load with RB

6. RB Apps and CPU usage

7. Using API NetMessageBufferSend: Nothing!

8. Windows programs using nothing but assembly language

9. Using cgi.FieldStorage with enctype=multipart/form-data in SimpleHTTPServer = nothing

10. SQL error retry message on insert - even when using TryInsert

11. using evens in define..

12. DVF's GETCHARQQ error even when using a string

 

 
Powered by phpBB® Forum Software