Indexes and attached tables 
Author Message
 Indexes and attached tables

Hi

[Using Access95, Jet3.0]

I've got a front-end/back-end app which 2-4 people are using.

When both are using the system and trying to ADD (not edit) records, they
get a 'duplicate value in index/primary key' error. There is only 1 index in
the underlying table, and that is primary key, autonumber. I didn't have any
problems when I was using Jet 2.5.

I don't think the error can really be a duplicate as it happens virtually
all the time. I was wondering if it is something to do with the way the
front-end handles the index from the back-end.

Can anyone shed any light on this as I am struggling.

Thanks

Simon



Sun, 21 Oct 2001 03:00:00 GMT  
 Indexes and attached tables
Simon,

Do you have any fields that are required that may not be being set to a value?

Just a thought ....
Mark

Quote:

> Hi

> [Using Access95, Jet3.0]

> I've got a front-end/back-end app which 2-4 people are using.

> When both are using the system and trying to ADD (not edit) records, they
> get a 'duplicate value in index/primary key' error. There is only 1 index in
> the underlying table, and that is primary key, autonumber. I didn't have any
> problems when I was using Jet 2.5.

> I don't think the error can really be a duplicate as it happens virtually
> all the time. I was wondering if it is something to do with the way the
> front-end handles the index from the back-end.

> Can anyone shed any light on this as I am struggling.

> Thanks

> Simon



Sun, 21 Oct 2001 03:00:00 GMT  
 Indexes and attached tables

Quote:
> When both are using the system and trying to ADD (not edit) records, they
> get a 'duplicate value in index/primary key' error. There is only 1 index in
> the underlying table, and that is primary key, autonumber. I didn't have any
> problems when I was using Jet 2.5.

This is probably not the answer you want to hear, but some might say that
your problem is that you're using Access 95, and that the solution would
be to upgrade to Access 97.

If you must stick with Access 95, then do you have all of its bug fixes
installed on both machines?

--
Paul Bredbury, http://dialspace.dial.pipex.com/brebs/



Mon, 22 Oct 2001 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Problems of index with attached tables

2. How to create index in attached tables in Access?

3. Deleting an index from an attached table

4. Pb with indexes on Attached ODBC tables

5. Attached table and not attached table

6. Attached tables, identifying users and un-attaching

7. Attached tables, identifying users and un-attaching

8. How to insert data from un-indexed tabel to indexed table

9. attached tables vs local tables

10. Please help with linked table or attached table

11. How to get table's index in the tables collection

12. Too many indexes - Wierd hidden indexes preventing index add

 

 
Powered by phpBB® Forum Software