Acc2000: Access tables attached to SQL-Server won't update 
Author Message
 Acc2000: Access tables attached to SQL-Server won't update

Running the query below returns 1 record in Access 2000. The same
query being run from Acc97 returns 5 records as it should.

I've tried closing Access completely and opening it again, but still
it only returns 1 record.

I am 100% sure that the SQL-statement is the same for both 97 and
2000.

If I from Enterprise Manager change values for the field RettetIni to
'sa', rerunning the query from Acc97 reflects the changes at once, but
even when shutting down Access 2000 I only get one record in return.
The record being returned from 2K is the same each time I run the
query. Any idea why??

--Sql-statement I use from Access:---
SELECT dbo_Person.Fornavnr, dbo_Person.RettetIni,
dbo_Person.RettetDato
FROM dbo_Person
WHERE dbo_Person.RettetIni="sa";
---

---
Mvh
Morten Snedker
www.access-dk.mobilixnet.dk



Sun, 17 Mar 2002 03:00:00 GMT  
 Acc2000: Access tables attached to SQL-Server won't update
If both versions of Access are attached to the same SQL Server, run a trace
(SQL Trace in 6.5, Profiler in 7.0) and look at the SQL that is actually
going into the server.

--
Bob Pfeiff
MCDBA, MCSD, MCSE, MCT, SQL Server MVP
Practice Leader, Data Management
CIBER, Washington, DC



Fri, 22 Mar 2002 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. Updating attached SQL Server Tables

2. SQL Server with Access Attach table?

3. Updating A SQL server table through DAO and ODBC In Access 2000

4. Open attached SQL Server table w/out prompting

5. Updating SQL60 database from a attached ACCESS table

6. Attached SQL Server Table

7. Attached SQL Server Table

8. Attaching to SQL server tables

9. Error updating attached MS-Access 2.0 tables

10. TITLE field won't update in header table

11. ADO .NET won't update table

12. Update SQL Syntax to Access and SQL Server

 

 
Powered by phpBB® Forum Software