Direct 1.0 Type Library Unreferenced 
Author Message
 Direct 1.0 Type Library Unreferenced

I get a call from a client every few weeks complaining that none of his
forms/reports using Date() or Now() work.

The first time this happened I checked and unchecked references at random
until I found the culprit (none were shown as MISSING). It turned out that the
"Direct 1.0 Type Library" had become unreferenced and after including this
library the system worked as it should. I could not explain how the reference
had been dropped, the only notable information being that the client had
installed IE 4.0 the day before and has yet to run the "MSOffice service pack
1".

As I said, since this first occurance the problem has reoccured several
times and I am at a loss to explain why.

Any suggestions ?

Dan

PS: To reply by e-mail, remove the "*NO SPAM* from my address.



Fri, 06 Oct 2000 03:00:00 GMT  
 Direct 1.0 Type Library Unreferenced

I have frequently encountered this problem as well especially when
transferring source code from one machine to another.  The references lookup
used by Microsoft could definitely use some work.  Why are standard VBA
functions tagged as being undefined when the VBA library is indeed
referenced properly and another library is to blame.  I have also
encountered this problem when upgrading custom ActiveX controls.  The only
remedy I've found is to create a new database and import all of the
applicable tables, queries, modules, etc., from the one with the messed up
references.  It would be nice if Microsoft would disconnect the missing
reference when one was found, instead of requiring it in order to run.
Maybe in Access 98 or 99.

C.D.Edwards

Quote:

>I get a call from a client every few weeks complaining that none of his
>forms/reports using Date() or Now() work.

>The first time this happened I checked and unchecked references at random
>until I found the culprit (none were shown as MISSING). It turned out that
the
>"Direct 1.0 Type Library" had become unreferenced and after including this
>library the system worked as it should. I could not explain how the
reference
>had been dropped, the only notable information being that the client had
>installed IE 4.0 the day before and has yet to run the "MSOffice service
pack
>1".

>As I said, since this first occurance the problem has reoccured several
>times and I am at a loss to explain why.

>Any suggestions ?

>Dan

>PS: To reply by e-mail, remove the "*NO SPAM* from my address.



Sat, 07 Oct 2000 03:00:00 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. CIC 1.0 Type Library

2. Preview 1.0 Type Library (shimgvw.dll - ImageView_Fullscreen)

3. Where can i find Com+ Services type library or Component services com+ 1.0 for Win98

4. How to use MSN Messenger 1.0 Type Library?

5. Using the MODELENGLib library (Microsoft Visio Database Modeling Engine Type Library)

6. Turbo Basic 1.0 And Libraries

7. Help on: Microsoft SQL Parser Object Library 1.0

8. data environment 1.0 library file help

9. ANNOUNCE: HTML Object Library 1.0

10. OLE/Messaging 1.0 Object Library

11. Fax com type lib 1.0

12. Fax com type lib 1.0

 

 
Powered by phpBB® Forum Software