connection with OLE server or ActiveX Control problem 
Author Message
 connection with OLE server or ActiveX Control problem

Hi ,

I have a form with several textboxes and a commandbutton.
Once the textboxes are filled I should be able to add this info to the
database.

Just when I push the button I get an ERROR MESSAGE indicating

"The expression On Click you entered as the event property setting produces
the following error :
  A problem occured while Microsoft Access was communicating with the OLE
server or ActiveX control"

I looked for uninstalled REFERENCES and installed all needed references.
I compiled the code , but there seems no problem with the code.
Can anyone tell me what i'm doing wrong or what is going wrong with this
code ??
Thanks for replying

Mario

I'm using these commands in my code

    dim Names , ............... as .......
    Dim RstRecord As DAO.Recordset
    Dim Db As DAO.Database

    Set Db = CurrentDb()
    Set rstRecord = Db.OpenRecordset("TblKlanten", dbOpenDynaset)

    Names = Me.txtNameClient.Value
    ....................
    ....................
    With rstRecord
        .AddNew
        !NameClient = Names
        !........................
        ....................
        .Update

    End With



Mon, 04 Oct 2004 22:34:53 GMT  
 connection with OLE server or ActiveX Control problem
Access can be a little goofy. I got the same message the
other day. Try launching the mdb wih the decompile
switch, immediatley close the mdb, create a new one and
import the objects.

Steve

Quote:
>-----Original Message-----
>Hi ,

>I have a form with several textboxes and a commandbutton.
>Once the textboxes are filled I should be able to add
this info to the
>database.

>Just when I push the button I get an ERROR MESSAGE
indicating

>"The expression On Click you entered as the event

property setting produces
Quote:
>the following error :
>  A problem occured while Microsoft Access was

communicating with the OLE
Quote:
>server or ActiveX control"

>I looked for uninstalled REFERENCES and installed all
needed references.
>I compiled the code , but there seems no problem with
the code.
>Can anyone tell me what i'm doing wrong or what is going
wrong with this
>code ??
>Thanks for replying

>Mario

>I'm using these commands in my code

>    dim Names , ............... as .......
>    Dim RstRecord As DAO.Recordset
>    Dim Db As DAO.Database

>    Set Db = CurrentDb()
>    Set rstRecord = Db.OpenRecordset("TblKlanten",
dbOpenDynaset)

>    Names = Me.txtNameClient.Value
>    ....................
>    ....................
>    With rstRecord
>        .AddNew
>        !NameClient = Names
>        !........................
>        ....................
>        .Update

>    End With

>.



Tue, 05 Oct 2004 03:35:28 GMT  
 
 [ 2 post ] 

 Relevant Pages 

1. HELP:OLE server to control multiple Database connections

2. VB5 ActiveX controls as OLE Servers?

3. VB5 ActiveX Controls as OLE Servers?

4. ActiveX Control Web Database Connection Problem

5. ActiveX Control Web Database Connection Problem

6. ActiveX Control Web Database Connection Problem

7. Problem deploying signed ActiveX Control on a web server

8. Problem deploying signed ActiveX Control on a web server

9. Problem deploying signed ActiveX Control on a web server

10. In-Process OLE Server and RDO Connection

11. OLE-Server with SQL-ODBC-Connection

12. In-Process OLE Server and RDO Connection

 

 
Powered by phpBB® Forum Software