Module Crazy Thing Happening 
Author Message
 Module Crazy Thing Happening

Since securing a new Access95 application (something I've done 10 or 20
times before) when I want to view ANY code a blank module windows appears
with a blank error dialog box
pressing Help results in Topic does not exist. Contact vendor ... (129)
I can mend the problem one object at a time by copy and pasting the object
but it comes back
I've tried all the usual steps like importing all the objects, repairing,
compacting etc but the problem comes back
When in the blank module window I tried compiling and some objects give
'Invalid Data Format' errors

It seems to be a side effect of the new permissions

I still have the original unsecured application and have resecured it with
the same results

This is what I do:

1. Create New Workgroup Information File
2. Create New Master User (Control)
3. Add Control to Admins
4. Remove Admin from Admins
5. Restart Access logged on as Control
6. Create New Database
7. Import all objects from unsecured Database
8. Create Groups, Users and assign permissions

Permissions are simple
Admins have full access
Control has full access
Some other groups provide Read/Edit on different chunks of the db

Ownership is simple
Control owns everything

Has anyone any clues as to what it happening?

TIA

corbin



Fri, 18 Aug 2000 03:00:00 GMT  
 Module Crazy Thing Happening

it seems to be down to a library database, even though the permissions are
totally open on it

something i don't know about?

corbin



Fri, 18 Aug 2000 03:00:00 GMT  
 Module Crazy Thing Happening

This seems to be an MS known problem - see MS Knowledge Base, and also
previous messages via DejaNews...

Quote:

> Since securing a new Access95 application (something I've done 10 or 20
> times before) when I want to view ANY code a blank module windows appears
> with a blank error dialog box
> pressing Help results in Topic does not exist. Contact vendor ... (129)
> I can mend the problem one object at a time by copy and pasting the object
> but it comes back
> I've tried all the usual steps like importing all the objects, repairing,
> compacting etc but the problem comes back
> When in the blank module window I tried compiling and some objects give
> 'Invalid Data Format' errors

> It seems to be a side effect of the new permissions

> I still have the original unsecured application and have resecured it with
> the same results

> This is what I do:

> 1. Create New Workgroup Information File
> 2. Create New Master User (Control)
> 3. Add Control to Admins
> 4. Remove Admin from Admins
> 5. Restart Access logged on as Control
> 6. Create New Database
> 7. Import all objects from unsecured Database
> 8. Create Groups, Users and assign permissions

> Permissions are simple
> Admins have full access
> Control has full access
> Some other groups provide Read/Edit on different chunks of the db

> Ownership is simple
> Control owns everything

> Has anyone any clues as to what it happening?

> TIA

> corbin

--


(To reply: please remove nSoPAM. from reply address - Thanks)



Sat, 19 Aug 2000 03:00:00 GMT  
 
 [ 3 post ] 

 Relevant Pages 

1. Craziest thing you've done with VBA?

2. Jane stop this crazy thing(or how to pause a macro)

3. Getting things to happen when you open word

4. Strange things are happening lately...

5. Help! Strange things happen when disabling Data Control

6. Strange thing happens after form unloads...

7. Wierd things happening ...

8. please help with MSCOMM.VBX: strange things happen

9. strange things are happening

10. Dirty things happen

11. Dirty things happen

12. Problems with StretchBlt, screwy thing happening.

 

 
Powered by phpBB® Forum Software