Macro not starting when starting word 97 with /m command 
Author Message
 Macro not starting when starting word 97 with /m command

When I start Word 97 with the following command line the
macro does not run

WINWORD /tMYTEMPLATE.dot /mMYMACRO

I can run the macro manually(tools menu) but it does not
run automatically.

Any ideas would be greatly appreciated.

Thanks



Sat, 04 Dec 2004 18:35:50 GMT  
 Macro not starting when starting word 97 with /m command
Does Word 97 have security features?  I just had a similar
problem with Word 2000.  It wouldn't run my "AutoOpen"
macro automatically as it should at file open time, but
would run OK manually.  I changed
Tools/Macro/Security/Security Level to Low and it worked
fine.  
Quote:
>-----Original Message-----
>When I start Word 97 with the following command line the
>macro does not run

>WINWORD /tMYTEMPLATE.dot /mMYMACRO

>I can run the macro manually(tools menu) but it does not
>run automatically.

>Any ideas would be greatly appreciated.

>Thanks
>.



Sun, 05 Dec 2004 21:58:20 GMT  
 Macro not starting when starting word 97 with /m command
Quote:
>-----Original Message-----
>Does Word 97 have security features?  I just had a
similar
>problem with Word 2000.  It wouldn't run my "AutoOpen"
>macro automatically as it should at file open time, but
>would run OK manually.  I changed
>Tools/Macro/Security/Security Level to Low and it worked
>fine.  

>>-----Original Message-----
>>When I start Word 97 with the following command line the
>>macro does not run

>>WINWORD /tMYTEMPLATE.dot /mMYMACRO

>>I can run the macro manually(tools menu) but it does not
>>run automatically.

>>Any ideas would be greatly appreciated.

>>Thanks
>>.

>.
>The only security feature I can find is in Tools-Options-

General.  It requests permission to run automatic macros.
It is turned off so I don't think that is the problem.  
But it was a good thought.
Thanks
Terry


Sun, 05 Dec 2004 23:06:07 GMT  
 Macro not starting when starting word 97 with /m command
Hi,

Ive seen something like this also. You can try adding a
self-certified code certificate this then should pop up on
any machine when HIGH security is selected. If your
certificate is installed then the Macros should run even
with this setting. Also it might be worth checking in your
views | toolbars | control toobox, menu to see if design
mode is selected, this will stop any embedded buttons and
or controls working in the document (as it will be in
design mode)

Medium security should propmt you, but them allow the
Macros to run

Cheers

Markie

Quote:
>-----Original Message-----
>Does Word 97 have security features?  I just had a
similar
>problem with Word 2000.  It wouldn't run my "AutoOpen"
>macro automatically as it should at file open time, but
>would run OK manually.  I changed
>Tools/Macro/Security/Security Level to Low and it worked
>fine.  

>>-----Original Message-----
>>When I start Word 97 with the following command line the
>>macro does not run

>>WINWORD /tMYTEMPLATE.dot /mMYMACRO

>>I can run the macro manually(tools menu) but it does not
>>run automatically.

>>Any ideas would be greatly appreciated.

>>Thanks
>>.

>.



Sun, 05 Dec 2004 23:14:09 GMT  
 
 [ 4 post ] 

 Relevant Pages 

1. Word 97 SR-1 - Macro command for Application.SaveAs does not save in HTML format

2. Start Word and macro from command line

3. Problem starting Acces 97 after having started Outlook 2000

4. Start a word doc template from Access 97

5. Start a macro automaticly when starting outlook

6. Word 97 Macros > Word XP Macros

7. Word not beeing started (not fast enough)

8. Start .exe from Word Macro?

9. Word VBA AutoNew macros fail to start

10. how to start Word, run a macro, wait till it finishes, then quit

11. Starting macros at Word XP startup

12. DDEEXECUTE to start a macro using Word 2000

 

 
Powered by phpBB® Forum Software